Modeler doesnt open - Mendix Forum

Modeler doesnt open

0

Hi,

Since version 7.21 of the Mendix Modeler, it doesn't open anymore on my laptop, using Windows 10 Pro. 7.20.1 and all previous versions work fine.

It does show the icon in my task bar and also has the process running in my task manager but when I click on it, nothing happens beside showing the small window. No idea what't going on here..

Any help is appreciated :)

In the meantime I tried:

- ALT+TAB
- Windows key + TAB
- Changed resolution
- Restart windows
- Re-install Mendix

 

 

asked
7 answers
3

We found the issue. We received the settings file from Sebastiaan and found that the Modeler started off screen. There is code to put the Modeler somewhere visible but something went wrong there. We will investigate further.

Three workarounds:

  • Make sure the Modeler is focused by Alt+Tabbing to it. Press Alt+Space. If a menu appears, choose Move, use one of the arrow keys on your keyboard and then move your mouse. The Modeler should be attached to your mouse and you can place it somewhere visible.
  • If the menu does not appear, the Sign-in or some other dialog may be on top of the Modeler main window. Press Escape and then retry the first workaround.
  • The final workaround is to remove the settings file out of the Modeler so that it will start in the default location again. However, you will lose a lot of preferences, like your docking layout. To remove the settings, go to %localappdata%\Mendix\ in the Windows File Explorer. Rename Settings.sqlite to Settings.sqlite.bak. The Modeler should open again.

 

Of course, we are going to look into the bug that the Modeler fails to start on one of the currently connected displays.

 

answered
1

I had this problem before and what I do when it happens is:

- hover over the Mx Modeler icon on taskbar

- right click on the thumbnail image

- select Maximize (or Restore - can't remember)

 

answered
1

I solved it by using CTRL+SHIFT and (right)clicking the icon in the taskbar. Then select maximize and it works again!

answered
0

Perhaps one of these tricks will help get the windows back on your screen: https://www.technipages.com/bring-off-screen-window-back-onto-screen

answered
0

As Austin mentioned, maybe it opens off screen.  I have found that happens for me with 7.21 when I deploy a new version to the cloud.

answered
0

Does it show up when you press alt + tab?

Possibly opened off screen? You can try changing your resolution to see if that moves all the windows to the main screen. 

Or maybe it opened on a different virtual desktop? Using alt + tab you can see all the desktops at the top. 

answered
0

Things you probably have tried so far:

- open windows task manager and delete processes called Mendix Modeler

- reboot your laptop

- de-install the modeler 7.21 and reinstall it

answered