Community Commons no longer has the commons-codec-1.10.jar but RestServices module needs it - Mendix Forum

Community Commons no longer has the commons-codec-1.10.jar but RestServices module needs it

0

Hi,

 

Just to avoid others losing time over this: Recent updates of Community Commons no longer have commons-codec-1.10.jar. However, the RestServices module needs it. I created ticket  77967 for this. 

 

For now, just grab commons-codec-1.10.jar from another project and put it back in. Or, if you just updated or migrated, take it from a branch.

 

The Java compile error if you open the error popup in the modeler:

compile:
    [javac] Compiling 226 source files to 
    [javac] <... > \javasource\restservices\util\Utils.java:15: error: package org.apache.commons.codec.digest does not exist
    [javac] import org.apache.commons.codec.digest.DigestUtils;
    [javac]                                       ^
    [javac] <...> \javasource\restservices\util\Utils.java:94: error: cannot find symbol
    [javac] 		return DigestUtils.md5Hex(jsonString.getBytes(RestServices.UTF8));
    [javac] 		       ^
    [javac]   symbol:   variable DigestUtils
    [javac]   location: class Utils
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
    [javac] 2 errors


 

asked
0 answers