Deeplink on ARABIC Language redirects to a landing page - Mendix Forum

Deeplink on ARABIC Language redirects to a landing page

0

I have a custom landing page(nothing fancy, some texts) which is anonymous.

Default Homepage(in navigation) is set to a MF which has the DeeplinkHome MF inside it from the appstore module and if there is no deeplink to serve, it will show my landing page. A typical setup i can say!

Now, using a deeplink i call microflow(allow guests true) to show a page, but before that i change the currentUser(anonymous) language to ARABIC and then show the page. This page has the URL set to it without any Objects(like /p/arabiannights/ BUT NOT /p/arabiannights/{id}). So you get the idea that this page doesnt need an object to show. Page is set with Allowed Roles = Anonymous.

But for some reason this always redirects me to the Landing page which i have setup as per above. But if dont set the language as Arabic i see the correct page!!!!

So i am not able to understand this. Any hints/ideas/your experiences before i do a deepdive on this :)

asked
2 answers
1

Am I understanding correctly that you have set the Page URL property (meaning users can directly access the page without deeplink), but you are still using the deeplink module to open the page? If so, are you only doing this to change the language?

I've experienced the issue you are describing where users are redirected to landing page, but that usually happened when the input object for the deeplink returns empty. So it's strange since you have said that the page is not expecting an input object.

My guess is that the URL might be malformed for some reason during the process, although I have no idea why that would happen when using the Arabic language, as apposed to it working when setting to English.

There are multiple previous questions with regards to changing an anonymous user's language, not sure if you've been through them, but if you search for "anonymous change language" you can have a look at those - seems pretty tricky indeed, and you have to take things into consideration like if the client side is aware of the language change.

Have you tried debugging with log level set to debug? Curious to see if there are any errors/warnings like "No session found for deeplink" ??

answered
1

Hello Ganesh,

Not sure if this is the issue you're facing, but I always found that User changes wouldn't affect a User until a they log out and log back in (For example role changes)

 

answered